RosettaVIP: ERROR: seqpos <= size()

Member Site Forums Rosetta 3 Rosetta 3 – Applications RosettaVIP: ERROR: seqpos <= size()

Viewing 1 reply thread
  • Author
    • #1356

        Hi, I tried RosettaVIP shipped in Rosetta3.4. In some cases it breaks after a few iterations with this error:

        ERROR: seqpos <= size()
        ERROR:: Exit from: src/core/conformation/Conformation.hh line: 289

        I can not figure out the root for the error from the source file. The command line I used is:

        vip.linuxgccrelease -s mypdb -cp:cutoff 6.0 -sasa_calculator_probe_radius 1.0 -cp:output myoutput -cp:print_reports -run:silent

        I have not observed other anomalies in the screen printout before the ERROR, neither in the reports.txt file.

      • #7467

          Turn off -run:silent and see if there are more messages relating to the error? That message itself it just a generic message saying that the code tried to access a residue that doesn’t exist (say, residue 101 of a 100 residue protein).

        • #7470

            I turned off the silent switch and ran VIP again. Sometimes I could reproduce the ERROR (I guess because RosettaHoles used in VIP is stochastic (see RosettaVIP manual)). Whenever the ERROR happens, I see a very strange energy value (no other WARNINGs or ERRORs observed):

            Total weighted score: -255.319
            VIP: Comparing new energy 1.73326e-316 with old energy -255.193
            VIP: Rejecting attempted mutation - finished!

          • #7473

              Stochastic errors like this are generally due to bugs in the code, not errors in your input. Can you share your input data so that I can see if I can reproduce it? I’ll file a bug report in our tracking system either way and bring it to the attention of the code’s author.

            • #7477

                This is the author’s comment:

                “Yeah, I’m aware of the error… it occurs when RosettaHoles doesn’t find any voids. Holes fills voids with cavity balls, which I essentially tacked on to the pose as extra ‘residues’, so if there are none, vip tries to read the first cavity ball and crashes, hence the seqpos error. Because the cavity finding is stochastic, the error is also, however, it shouldn’t cause any problems aside from being a bit annoying.

                I’ll implement a more elegant exit at some point and it will be fixed for the next release.”

              • #7486

                  Thanks a lot for the help!

                  As a matter of fact, it does cause another problem: the final PDB file is empty if this error is reported.

              Viewing 1 reply thread
              • You must be logged in to reply to this topic.