• This topic has 1 reply, 2 voices, and was last updated 10 years ago by Anonymous.
Viewing 1 reply thread
  • Author
    Posts
    • #1887
      Anonymous

        Hello:

        I am compiling version 3.5 with command:

        scons bin mode=release extras=static extras=mpi -j6

        it finished successfully without any errors. However, I found that all the tools are named with ***mpi, such as:

        homodimer_design.mpi.linuxgccrelease

        I am just wondering, with the command I used, does it also a static compiled version?

        thx a lot

      • #10043
        Anonymous

          I’m thinking that by adding extras on the commandline twice you overwrote the option, rather than added to it. If you want to have multiple extras, you need to specify it once with comma separation: “extras=mpi,static”

          Note that in combining these two particular settings you need to be careful that the MPI libraries and environment on your system are set up for static compilation. Settings that work for dynamic linkage may not work for static linkage, and that’s entirely dependent on your MPI library installation.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.