UBQ chemically conjugated docking error

Member Site Forums Rosetta 3 Rosetta 3 – General UBQ chemically conjugated docking error

Viewing 1 reply thread
  • Author
    • #2289

        Hi Rosetta Users,

        I have been trying out the “UBQ chemically conjugated docking” protocol with a multicomponent system including protein+DNA as the input. I used the UBQ_Gp_LYX-Cterm application to attach the ubiquitin to a lysine residue in one of the protein chains in the protein/DNA complex. The options file is basically the same as provided in the demo. I added the DNA molecule as well as other protein chains (except the target chain to be ubiquitinated) using the flag –chemically_conjugated_docking:extra_bodies. But the following error occurred:


        apps.public.scenarios.chemically_conjugated_docking.UBQ_Gp_LYX-Cterm: Current Low total cycles =100 apps.public.scenarios.chemically_conjugated_docking.UBQ_Gp_LYX-Cterm: 1 122031 122031 core.mm.MMTorsionLibrary: MM torsion sets added fully assigned: 766; wildcard: 43 and 1 virtual parameter. core.mm.MMTorsionLibrary: No parameters for CN7-ON2-P-ON3


        ERROR:: Exit from: src/core/scoring/mm/MMTorsionLibrary.cc line: 221

        I guess it means there are missing parameters for the DNA molecule in the system, because when I removed the DNA, the program ran smoothly. Any idea how to fix this issue? Thanks.


      • #11215

          You have correctly identified the problem: no mm torsion params for the DNA.

          Look at Rosetta/main/database/chemical/mm_atom_type_sets/fa_standard/mm_torsion_params.txt.  It’s like so:

          #atom1    atom2   atom3   atom4   strength, periodicity, minimum

          C    S    CT2    CT1    0.2400    1    180.00 #wild guess, borrowed from CT3-S-CT2-CT2 (methionine)


          Strength, perioditicy, minimum define a trig function (sin or cosine, I forget) with the desired amplitude, perioditicy, and phase.  The 4 atoms are mm atom types (referenced from the PDB atom types in the DNA params files in database/chemical/residue_type_sets/fa_standard/residue_types/nucleic/dna).  

          As to what your params should be…I don’t know.  The DNA isn’t moving during the step that uses the MM terms unless you’ve used the DNA as part of the chemical connection, so just define 0 0 0 functions for all atom quadruplets you need.  The code wants to MM score all atom quads but it only uses the ones at the chemical conjugation.  For a horror show, check for SML’s commentary (me) in the mm_torsion_params file for suggestions on how I made up the params used in the UBQ code you’re using.

        • #11217

            Thanks a lot for your reply. Just a follow-up question, is there any existing list that contains all atom quadruplets for DNA molecules? If not, I guess I will probably need to create such a list with all atom types from DNA params files by shuffling the atom1, atom2, atom3, atom4 columns. But that will create a huge long list with many redundant and physically infeasible atom combinations. 

          • #11221

              The MM parameters actually originally come from the CHARMM parameter files. There’s a number of different versions floating around on the internet, and if you get lucky, you may be able to find one which has all the DNA parameters in a similar format.

              The other shortcut is that you can use the “X” MM atom type as an “any” entry, so you can make mock parameters for your entries without having to worry about the full 4-atom combinitorial explosion.

              The other possiblity, if the error occurs relatively early in the run, is to just add the parameter lines one-by-one as Rosetta errors out on them. With a quick run and the parameter file opened up in a window alongside your terminal, it should be relatively easy to do a run-error-fix-rerun cycle.


            • #11222

                Thanks so much. I tried the second method using “X” MM atom type, and it worked nicely. I believe the first method should also work if I find copy those DNA  parameters from CHARMM params files.

            Viewing 1 reply thread
            • You must be logged in to reply to this topic.