Unable to set up interface foldtree because there are no movable jumps – (antibody/antigen docking)

Member Site Forums Rosetta 3 Rosetta 3 – Applications Unable to set up interface foldtree because there are no movable jumps – (antibody/antigen docking)

  • This topic has 2 replies, 3 voices, and was last updated 10 years ago by Anonymous.
Viewing 2 reply threads
  • Author
    Posts
    • #1870
      Anonymous

        Hi,

        I’ve been using Rosetta to generate models of antibody-antigen interactions. I’m using the 2014wk05 release to do the following:
        I use an antibody downloaded form pdb (4KVN) remove the chain A, hetatm and waters in pymol then load in the new antigen (generated using I-Tasser and free of heteroatoms etc.), this joined file is then saved and fed in to rosetta scripts with the following flags:

        -docking
        -dock_pert 8 5
        -spin 1
        -randomize1
        -docking_centroid_outer_cycles 10
        -docking_centroid_inner_cycles 50
        -docking:dock_mcm_trans_magnitude .1
        -docking:dock_mcm_rot_magnitude 1

        -nstruct 100

        -database /path/to/rosetta_2014wk05_bundle/main/database

        -linmem_ig 10

        -ex1

        -ex2

        -ex1aro

        -overwrite

        -parser:protocol '/path/to/parameters_rosetta/docking.xml'

        -packing:repack_only

        -restore_pre_talaris_2013_behavior

        -out:pdb

        -partners HL_A

        -use_input_sc

        This is the Docking.xml I’m using:

        < dock_design >
        < SCOREFXNS >
        < /SCOREFXNS>
        < TASKOPERATIONS >
        < InitializeFromCommandline name=ifcl />
        < /TASKOPERATIONS >
        < FILTERS >
        < /FILTERS >
        < MOVERS >
        < Docking name=dock_low score_low=score_docking_low score_high=score12 fullatom=0 local_refine=0 optimize_fold_tree=1 conserve_foldtree=1 design=0 task_operations=ifcl />
        < Docking name=dock_high score_low=score_docking_low score_high=score12 fullatom=1 local_refine=1 optimize_fold_tree=1 conserve_foldtree=1 design=0 task_operations=ifcl />
        < PackRotamersMover name=pr scorefxn=score12 />
        < MinMover name=min scorefxn=score12 chi=1 bb=1 jump=1 tolerance=0.01 />

        < APPLY_TO_POSE >
        < /APPLY_TO_POSE >
        < PROTOCOLS >
        < Add mover_name=dock_low />
        < Add mover_name=pr />
        < Add mover_name=min />
        < Add mover_name=dock_high />
        < Add mover_name=pr />
        < Add mover_name=min />
        < /PROTOCOLS >
        < /dock_design >

        This had been working pretty well up until my last few models where I am now getting the following error:
        ERROR: Unable to set up interface foldtree because there are no movable jumps
        ERROR:: Exit from: src/protocols/docking/util.cc line: 289

        I’ve tried a number of different flags, I tried adding a -native flag but nothing seems to help. The only other thing different about these files is that they contained a hydoxylated PRO resn so I had to modify the patches.txt to add a patches/pro_hydroxylated_case1.txt line to correct the initially error I was getting.

        So my guess is that it has something to do with that but after a few days of searching and attempting solutions on my own I’ve come up empty. Any guidance is appreciated and I’m happy to share the pdb file I’m using if that helps.

        On a more general note I’m still sorting things out with flags and options so if there are any optimized options anyone has come across from generating antibody-antigen models like this please feel free to give your feedback, any help is appreciated.

      • #10008
        Anonymous

          It’s hard to say without seeing the exact PDB file you’re using as input, but it sounds like for some reason Rosetta is thinking that everything in your protein is one chain. Which either means that it’s discarding chains, or it’s mashing multiple chains together.

          The first thing I’d check is that in your input PDB you have separate H, L and A chains (as you’re using the partners designation of HL_A). I’d also check that the occupancy column of your PDB is not zero for any of the chains. An easy way to check that your PDB is being read correctly is to use the score_jd2 application with the “-out:pdb” flag. You’ll get a “_0001.pdb” which should contain what Rosetta thinks your protein looks like – check to make sure it make sense.

          If score_jd2 is reading in & outputting everything in correctly, there may be something about the protocol itself which is invalidating the chain designations. This can sometimes happen if residues are added or deleted during the run – Rosetta doesn’t know what to do with the added residues regarding PDB numbering, so it just renumbers everything in pose numbering. I don’t see where that would be happening with your runs, though.

          You mention that some of your runs previously worked. Do you remember what you changed between the runs that worked and the ones that didn’t?

        • #10050
          Anonymous

            Also, check to make sure that your PDB file has the same order as the partners flag – aka the order of the chains in the PDB file are H->L->A. The docking foldtree for the -partners flag currently requires this. Also note that if you use any of the antibody modeling code, most of the foldtrees are hardcoded (currently) to have the PDB order be LHA. You will get strange results otherwise.

        Viewing 2 reply threads
        • You must be logged in to reply to this topic.