“Unhandled exception” error while running on Windows

Member Site Forums Rosetta++ Rosetta++ – Build/Install “Unhandled exception” error while running on Windows

Viewing 3 reply threads
  • Author
    • #708


        I have successfully installed Rosetta3.1 on Windows 7 (64-bit) using Visual C++ 2005. I am trying to perform de novo structure determination.

        Every time I try to run -prna, I am stopped halfway through and given the following error:
        “Unhandled exception at 0x004e2a6f in rosetta++.vc.release.exe: oxC0000094: Integer divison by zero.”

        Google searching suggested I perform a reinstall, but I’ve tried and received the same error. I have very limited programming knowledge, so this error means nothing to me. Any help will be appreciated!


      • #4701

          Are you using 3.1 or 2? You say 3.1, but your executeable name “rosetta++.vc.release.exe” is more consistent with a rosetta 2 build (maybe?) If it’s 3.1, which of the many executeables is this?

          As a general rule, for problems like this, try compiling in debug mode (mode=debug instead of mode=release) and you may get a more informative error message (or maybe just a line number of failure…)

          • #4702

              Oops, I have 2.3 installed, not 3.1, sorry.

              When compiling in debug mode, the program crashes, and the error in the scripting says:

              Assertion failed: exp2_p_->value() !=0.0, file c:….rosetta++srcObjexxFCL/DimensionExpressionDiv.hh, line 210

              Here are the relevant lines in the file:
              207 /// @brief DimensionExpression != DimensionExpression
              208 inline
              209 bool
              210 operator !=( DimensionExpression const & exp1, DimensionExpression const & exp2 )
              211 {
              212 return !( exp1 == exp2 );
              213 }

          • #4703

              We’d need to debug it further to see where it’s crashing – this is literally where it’s crashing, but functionally too low to be useful. (Think of a car crash; we need to know why the car swerved off the road, not which tree it hit).

              Do you know who is responsible for this prna mode? If it’s for RNA it’s likely to be Rhiju Das. It may be more useful to contact him. I know very little about ++ and nothing about this in particular.

            • #4705

                Thanks for your help (and the great analogy)! Somehow, I got around the error, but all I really did was change the filename and command closer to what the tutorial suggests. I intend to play around and try to find exactly what works and doesn’t work, and I will reply with an update if I’m successful. For now, I’ve run into a different error, but it has nothing to do with the coding, so I should be able to troubleshoot around it.

                After getting annoyed with Windows, I installed Rosetta3.1 on a Mac computer, and everything seems to be going well.

            Viewing 3 reply threads
            • You must be logged in to reply to this topic.