where is pdb2vall.py

Member Site Forums Rosetta 3 Rosetta 3 – Applications where is pdb2vall.py

Viewing 3 reply threads
  • Author
    • #1504

        Where can I find pdb2vall.py script to add extra pdb structures to the fragment libraries? I’ve searched through Rosetta3.4 bundle, Rosetta3.3_fragments and PyRosetta but couldn’t find it.

      • #8340

          I can see it at ./rosetta_tools/fragment_tools/pdb2vall/pdb2vall.py. I’ve attached it.

        • #8353

            In the README file from the pdb2vall folder:

            3. Edit pdb2vall.cfg:

            you need to modify the configuration file to give correct paths for scripts/databases.

          • #8354

              In addition to reading the README and following the installation directions which includes editing the config file:

              it looks like the script that installs/updates the PDB data (which is missing and causing the error) will only install/update Tues-Thursday to save bandwidth.

              As a quick fix:

              edit database/rcsb_data/update_rcsb_data.pl

              by commenting out the line:

              exit(0) if ($wday < 2 || $wday > 4);

              line 10.

              and then rerun the main pdb2vall script.
              If that gives the same error, run ./database/rcsb_data/update_rcsb_data.pl and then rerun the main script.

            • #8341


                I get an error I encountered with other python scripts from the Rosetta 3.4 bundle as well. I am using CentOS 6.3 64-bit, do you have any idea what package is needed?

                $ python /home/thomas/Programs/Rosetta3.4/rosetta_tools/fragment_tools/pdb2vall/pdb2vall.py –help
                Traceback (most recent call last):
                File “/home/thomas/Programs/Rosetta3.4/rosetta_tools/fragment_tools/pdb2vall/pdb2vall.py”, line 8, in
                from amino_acids import longer_names
                ImportError: No module named amino_acids

              • #8343

                  I don’t have a copy of 3.4 tools handy. Using the developer-trunk version, it appears to be looking for “amino_acids.py” in the same directory. Is that not there for you? I can make you a copy of the whole directory.

                  EDIT: I looked into the 3.4 release…none of this stuff is there! I guess it’s newer than 3.4. I have made a copy of this whole directory off developer trunk for you and temporarily stashed it at http://rosettadesign.med.unc.edu/collaborators/RosettaTutorial/pdb2vall.tar.gz since it’s too large to attach. I’ll delete it after you signal that you downloaded it.

                • #8350

                    Thanks for the archive. I tried to run pdb2vall.py but got the following error:

                    $ python /home/thomas/Programs/Rosetta3.4/rosetta_tools/fragment_tools/pdb2vall/pdb2vall.py –no_structure_profile -d -p 4h99M
                    pdb2vall.py: getting fasta from pdb_seqres.txt …
                    Traceback (most recent call last):
                    File “/home/thomas/Programs/Rosetta3.4/rosetta_tools/fragment_tools/pdb2vall/pdb2vall.py”, line 75, in
                    tmp_results = numbering_back_to_pdbseqres( pdb )
                    File “/home/thomas/Programs/Rosetta3.4/rosetta_tools/fragment_tools/pdb2vall/numbering_back_to_pdbseqres.py”, line 48, in numbering_back_to_pdbseqres
                    file = open( pdb_seqres_fn, “r”)
                    IOError: [Errno 2] No such file or directory: ‘/home/thomas/Programs/Rosetta3.4/rosetta_tools/fragment_tools/pdb2vall/database/rcsb_data/derived_data/pdb_seqres.txt’

                    Is the directory you sent me complete?

                  • #8351

                      The file “rosetta_tools/fragment_tools/pdb2vall/database/rcsb_data/derived_data/pdb_seqres.txt” does not exist in developer’s trunk. (The whole subdirectory derived_data does not exist). The README implies:

                      Databases which may need to be updated in the future:

                      derived_data ss_dis.txt

                      So apparently that file was either left out as incomplete, or you should supply an updated version somehow? I’ve contacted the code’s authors for comment.

                  Viewing 3 reply threads
                  • You must be logged in to reply to this topic.